package/bird: bump to version 2.0.8
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 21 Jul 2021 06:45:14 +0000 (08:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 21 Jul 2021 07:25:51 +0000 (09:25 +0200)
- Drop patches (already in version)
- Update indentation in hash file (two spaces)

https://gitlab.nic.cz/labs/bird/-/blob/v2.0.8/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bird/0001-Nest-Fix-build-without-protocols.patch [deleted file]
package/bird/0002-Added-missing-extern.patch [deleted file]
package/bird/bird.hash
package/bird/bird.mk

diff --git a/package/bird/0001-Nest-Fix-build-without-protocols.patch b/package/bird/0001-Nest-Fix-build-without-protocols.patch
deleted file mode 100644 (file)
index 48d2144..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From f9eb9b4cab65b850c61738dd56632bae0e7329ca Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sat, 19 Oct 2019 12:50:27 +0200
-Subject: [PATCH] Nest: Fix build without protocols
-
-(CHECK keyword added by commiter)
-[Retrieved from:
-https://gitlab.labs.nic.cz/labs/bird/commit/f9eb9b4cab65b850c61738dd56632bae0e7329ca]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- nest/config.Y | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/nest/config.Y b/nest/config.Y
-index c62501a3..1bc203dd 100644
---- a/nest/config.Y
-+++ b/nest/config.Y
-@@ -75,6 +75,7 @@ CF_KEYWORDS(BGP, PASSWORDS, DESCRIPTION, SORTED)
- CF_KEYWORDS(RELOAD, IN, OUT, MRTDUMP, MESSAGES, RESTRICT, MEMORY, IGP_METRIC, CLASS, DSCP)
- CF_KEYWORDS(TIMEFORMAT, ISO, SHORT, LONG, ROUTE, PROTOCOL, BASE, LOG, S, MS, US)
- CF_KEYWORDS(GRACEFUL, RESTART, WAIT, MAX, FLUSH, AS)
-+CF_KEYWORDS(CHECK, LINK)
- /* For r_args_channel */
- CF_KEYWORDS(IPV4, IPV4_MC, IPV4_MPLS, IPV6, IPV6_MC, IPV6_MPLS, IPV6_SADR, VPN4, VPN4_MC, VPN4_MPLS, VPN6, VPN6_MC, VPN6_MPLS, ROA4, ROA6, FLOW4, FLOW6, MPLS, PRI, SEC)
--- 
-2.21.0
-
diff --git a/package/bird/0002-Added-missing-extern.patch b/package/bird/0002-Added-missing-extern.patch
deleted file mode 100644 (file)
index 00aab3e..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From 4bbc10614f3431c37e6352f5a6ea5c693c31021e Mon Sep 17 00:00:00 2001
-From: Maria Matejka <mq@ucw.cz>
-Date: Tue, 4 Feb 2020 10:11:16 +0100
-Subject: [PATCH] Added missing extern
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Thanks to Robert Scheck <bird@robert-scheck.de> who reported it
-and Toke Høiland-Jørgensen <toke@toke.dk> who suggested this patch.
-
-[Retrieved from:
-https://gitlab.nic.cz/labs/bird/-/commit/4bbc10614f3431c37e6352f5a6ea5c693c31021e]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- nest/route.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/nest/route.h b/nest/route.h
-index d2a07f09..b927db5f 100644
---- a/nest/route.h
-+++ b/nest/route.h
-@@ -458,7 +458,7 @@ typedef struct rta {
-                                          protocol-specific metric is availabe */
--const char * rta_dest_names[RTD_MAX];
-+extern const char * rta_dest_names[RTD_MAX];
- static inline const char *rta_dest_name(uint n)
- { return (n < RTD_MAX) ? rta_dest_names[n] : "???"; }
--- 
-2.26.2
-
index 303fc21205c637dbc9767161ac31340bd93c631b..2d20491dd603a27d4a9f60f51865dd263bfc7ce1 100644 (file)
@@ -1,2 +1,2 @@
-sha256 631d2b58aebdbd651aaa3c68c3756c02ebfe5b1e60d307771ea909eeaa5b1066  bird-2.0.7.tar.gz
-sha256 94c53c84320078920ac1f0d49c81a4e9004512f534521a58bdf145acbcbc2cd2  README
+sha256  19d2de83ee25a307b9e5b9e58797dd68766d439bcee33e3ac617ed502370e7f6  bird-2.0.8.tar.gz
+sha256  94c53c84320078920ac1f0d49c81a4e9004512f534521a58bdf145acbcbc2cd2  README
index 4d6159b075a6b1fc2c06feca5783e3425dc19ac2..a8b9b18b50b250468f6cd8cae85546fbdaa0f6a6 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BIRD_VERSION = 2.0.7
+BIRD_VERSION = 2.0.8
 BIRD_SITE = ftp://bird.network.cz/pub/bird
 BIRD_LICENSE = GPL-2.0+
 BIRD_LICENSE_FILES = README