armv8: Fix defconfig build
authorMaxime Ripard <maxime.ripard@free-electrons.com>
Mon, 6 May 2013 00:14:55 +0000 (00:14 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 6 May 2013 10:26:06 +0000 (12:26 +0200)
Commit 14f48861 ("arc: Add ARC and ARC BE architecture") introduced a
sed match against arc* buildroot architecture to translate it to arc.

This causes a problem with armv8, which is called in buildroot aarch64,
which is also matching, resulting in a build failure.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 1692a369c48d645662b5ce2c30b3995afbb65d3a..9128c7579622c23587ec70f1724091c85396e827 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -238,7 +238,8 @@ ARCH:=$(call qstrip,$(BR2_ARCH))
 
 KERNEL_ARCH:=$(shell echo "$(ARCH)" | sed -e "s/-.*//" \
        -e s/i.86/i386/ -e s/sun4u/sparc64/ \
-       -e s/arc.*/arc/ \
+       -e s/arcle/arc/ \
+       -e s/arcbe/arc/ \
        -e s/arm.*/arm/ -e s/sa110/arm/ \
        -e s/aarch64/arm64/ \
        -e s/bfin/blackfin/ \