systemd: fix build with libgcrypt enabled
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Mar 2016 18:00:20 +0000 (20:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Mar 2016 18:00:20 +0000 (20:00 +0200)
When gcrypt support is enabled, we need to tell systemd where
libgpg-error is installed.

Fixes:

  http://autobuild.buildroot.org/results/1fd6193ff33250565c95e53614f5aa7fc6f4581c/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd.mk

index 79e657e5f389c3fcd546752a7378e357bc2fb86d..75ad961d597a16a72d1604fa3b1eb879e87656f0 100644 (file)
@@ -115,7 +115,8 @@ ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 SYSTEMD_DEPENDENCIES += libgcrypt
 SYSTEMD_CONF_OPTS += \
        --enable-gcrypt \
-       --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+       --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
+       --with-libgpg-error-prefix=$(STAGING_DIR)/usr
 else
 SYSTEMD_CONF_OPTS += --disable-gcrypt
 endif