qt5base: add D-Bus support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 19 Mar 2013 09:29:37 +0000 (09:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Mar 2013 21:10:24 +0000 (22:10 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/qt5base/Config.in
package/qt5/qt5base/qt5base.mk

index 8b0291b54b174a5e589c15d231b78530365725d3..d313db9185c7a2a35a68f53b7b774215bee21263 100644 (file)
@@ -132,4 +132,12 @@ config BR2_PACKAGE_QT5BASE_PNG
 
 endif
 
+config BR2_PACKAGE_QT5BASE_DBUS
+       bool "DBus module"
+       select BR2_PACKAGE_DBUS
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
+       help
+         This option enables the D-Bus module.
+
 endif
index 65fe451e0250402460cda3acb6768d8c306763c2..62f0b9a9dda10eaddc5bdcc7d217fe13271ea9c0 100644 (file)
@@ -27,7 +27,6 @@ QT5BASE_CONFIGURE_OPTS += \
        -no-libudev \
        -no-iconv \
        -no-icu \
-       -no-dbus \
        -no-gstreamer \
        -no-gtkstyle \
        -system-zlib \
@@ -93,6 +92,9 @@ QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_JPEG),jpeg)
 QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_PNG),-system-libpng,-no-libpng)
 QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_PNG),libpng)
 
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_DBUS),-dbus,-no-dbus)
+QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_DBUS),dbus)
+
 # Build the list of libraries to be installed on the target
 QT5BASE_INSTALL_LIBS_y                                 += Qt5Core
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK)    += Qt5Network
@@ -105,6 +107,8 @@ QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_GUI)          += Qt5Gui
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_WIDGETS)      += Qt5Widgets
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_PRINTSUPPORT) += Qt5PrintSupport
 
+QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_DBUS) += Qt5DBus
+
 # Ideally, we could use -device-option to substitute variable values
 # in our linux-buildroot-g++/qmake.config, but this mechanism doesn't
 # nicely support variable values that contain spaces. So we use the