package/pure-ftpd: add optional mysql dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 12 Apr 2019 20:59:30 +0000 (22:59 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 13 Apr 2019 14:07:22 +0000 (16:07 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/pure-ftpd/pure-ftpd.mk

index a9268b444628bf0d12a8f42e81b55b86309066eb..93ad57c3f314674cffd7fd82d5f5e3a1d2b67152 100644 (file)
@@ -30,6 +30,13 @@ ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
 PURE_FTPD_DEPENDENCIES += libsodium
 endif
 
+ifeq ($(BR2_PACKAGE_MYSQL),y)
+PURE_FTPD_CONF_OPTS += --with-mysql=$(STAGING_DIR)/usr
+PURE_FTPD_DEPENDENCIES += mysql
+else
+PURE_FTPD_CONF_OPTS += --without-mysql
+endif
+
 ifeq ($(BR2_PACKAGE_OPENLDAP),y)
 PURE_FTPD_CONF_OPTS += --with-ldap
 PURE_FTPD_DEPENDENCIES += openldap