package/squid: use external libltdl
authorAlexander Dahl <post@lespocky.de>
Wed, 17 Mar 2021 06:01:45 +0000 (07:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Mar 2021 21:47:40 +0000 (22:47 +0100)
When enabling BR2_PACKAGE_LIBTOOL it depended on the build order if
squid used the external libltdl or built it from its internal copy. That
broke the build in fli4l where we have additional post build checks
analyzing runtime dependencies and a separate step for copying build
artefacts to target packages.

Depend on the external libltdl unconditionally like done with commit
3efc5a250c1c ("package/siproxd: new package") for package siproxd
recently as well. For reproducibility, size, and security.

Link: https://web.nettworks.org/ci/job/fli4l/job/buildroot/job/4.0/job/trunk-sunxi/672/
Suggested-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Alexander Dahl <post@lespocky.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/squid/Config.in
package/squid/squid.mk

index 726160b01d9ca012adb75bc3f9c80cff5342b55c..0df2aedef67ace171e953b6fb9ec380b9a6f68ed 100644 (file)
@@ -13,6 +13,7 @@ config BR2_PACKAGE_SQUID
        # needs fork()
        depends on BR2_USE_MMU
        select BR2_PACKAGE_LIBCAP
+       select BR2_PACKAGE_LIBTOOL
        select BR2_PACKAGE_LIBXML2
        help
          Caching proxy for the Web supporting HTTP, HTTPS, FTP, and
index 473af2ac1267466311e6de728a7ec3971b1a70a4..a3ccbbcf8e0f0e2b590948a1ae1d734225dc3167 100644 (file)
@@ -10,7 +10,7 @@ SQUID_SITE = http://www.squid-cache.org/Versions/v4
 SQUID_LICENSE = GPL-2.0+
 SQUID_LICENSE_FILES = COPYING
 SQUID_CPE_ID_VENDOR = squid-cache
-SQUID_DEPENDENCIES = libcap host-libcap libxml2 host-pkgconf \
+SQUID_DEPENDENCIES = libcap host-libcap libtool libxml2 host-pkgconf \
        $(if $(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),libnetfilter_conntrack)
 SQUID_CONF_ENV = \
        ac_cv_epoll_works=yes \
@@ -33,6 +33,8 @@ SQUID_CONF_OPTS = \
        --enable-auth-ntlm="fake" \
        --disable-strict-error-checking \
        --enable-external-acl-helpers="file_userip" \
+       --disable-ltdl-install \
+       --without-included-ltdl \
        --with-logdir=/var/log/squid/ \
        --with-pidfile=/var/run/squid.pid \
        --with-swapdir=/var/cache/squid/ \