skeleton: fix VCS folders not being excluded from rootfs
authorNathan Ford <nford@westpond.com>
Wed, 30 Dec 2015 22:46:04 +0000 (17:46 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 31 Dec 2015 09:35:13 +0000 (10:35 +0100)
There is a typo in skeleton.mk preventing rsync from excluding VCS
folders such as .svn.

Signed-off-by: Nathan Ford <nford@westpond.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/skeleton/skeleton.mk

index 790afaf14693bdaffa45bc35eddd2b4bd06fa750..d640e247cbe997181bd6a2f3b7eb57e2647112b9 100644 (file)
@@ -78,7 +78,7 @@ endef
 endif
 
 define SKELETON_INSTALL_TARGET_CMDS
-       rsync -a --ignore-times $(SYNC_VCS_EXCLUSIONS) \
+       rsync -a --ignore-times $(RSYNC_VCS_EXCLUSIONS) \
                --chmod=u=rwX,go=rX --exclude .empty --exclude '*~' \
                $(SKELETON_PATH)/ $(TARGET_DIR)/
        $(call SKELETON_USR_SYMLINKS_OR_DIRS,$(TARGET_DIR))