Makefile: fix kernel modules test
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 25 Aug 2013 22:34:45 +0000 (00:34 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 25 Aug 2013 22:34:45 +0000 (00:34 +0200)
Commit fde2605765f (Makefile: test before search for kernel modules)
changed the way we strip kernel modules, but it fails when modules aren't
available (as test -d returns with a non zero exit code).

Fix it by including the test -d call in a proper shell conditional.

Reported-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 9f0164ed6c4172e987246004d2b088f4ec7e1645..ca7b039b6dc1d422833e306db365fbc731fa4a5f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -476,9 +476,9 @@ ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
        find $(TARGET_DIR)/usr/lib/ -name '*.py' -print0 | xargs -0 rm -f
 endif
        $(STRIP_FIND_CMD) | xargs $(STRIPCMD) 2>/dev/null || true
-       test -d $(TARGET_DIR)/lib/modules && \
+       if test -d $(TARGET_DIR)/lib/modules; then \
                find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
-               xargs -r $(KSTRIPCMD)
+               xargs -r $(KSTRIPCMD); fi
 
 # See http://sourceware.org/gdb/wiki/FAQ, "GDB does not see any threads
 # besides the one in which crash occurred; or SIGTRAP kills my program when