lxc: new package
authorJérôme Pouiller <jezz@sysmic.org>
Tue, 12 Feb 2013 11:21:26 +0000 (12:21 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 13 Aug 2013 21:09:34 +0000 (23:09 +0200)
Linux Containers (LXC), provides the ability to group and isolate
of a set of processes in a jail by virtualizing and accounting the
kernel resources. It is similar to Linux-Vserver or Openvz.

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lxc/Config.in [new file with mode: 0644]
package/lxc/lxc.mk [new file with mode: 0644]

index 2ee843ed5e47062316b0c892d3007152981a8818..23472297ebaa0a84d5177182309aae5188dfafa2 100644 (file)
@@ -903,6 +903,7 @@ source "package/cpuload/Config.in"
 source "package/htop/Config.in"
 source "package/keyutils/Config.in"
 source "package/kmod/Config.in"
+source "package/lxc/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/module-init-tools/Config.in"
 endif
diff --git a/package/lxc/Config.in b/package/lxc/Config.in
new file mode 100644 (file)
index 0000000..5e6e208
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LXC
+       bool "lxc"
+       select BR2_PACKAGE_LIBCAP
+       depends on BR2_INET_IPV6
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         Linux Containers (LXC), provides the ability to group and isolate
+         of a set of processes in a jail by virtualizing and accounting the
+         kernel resources. It is similar to Linux-Vserver or Openvz.
+
+         http://lxc.sourceforge.net/
+
+comment "lxc requires a toolchain with IPv6 and thread support"
+       depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/lxc/lxc.mk b/package/lxc/lxc.mk
new file mode 100644 (file)
index 0000000..4e06902
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# lxc
+#
+################################################################################
+
+LXC_VERSION = 0.9.0
+LXC_SITE = http://downloads.sourceforge.net/project/lxc/lxc/lxc-$(LXC_VERSION)
+LXC_LICENSE = LGPLv2.1+
+LXC_LICENSE_FILES = COPYING
+LXC_DEPENDENCIES = libcap
+LXC_CONF_OPT = --disable-apparmor
+
+$(eval $(autotools-package))