Fixup dropbearmulti build and install
authorEric Andersen <andersen@codepoet.org>
Mon, 10 Jan 2005 10:04:08 +0000 (10:04 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 10 Jan 2005 10:04:08 +0000 (10:04 -0000)
package/dropbear_sshd/dropbear_sshd.mk

index b7d9141b214f8eec284b51ea099d1f6ea20e9d57..26c9b17830af3f78a90c1900b4f0775041a62d67 100644 (file)
@@ -48,7 +48,8 @@ $(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
 
 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY): $(DROPBEAR_SSHD_DIR)/.configured
        $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
-               -C $(DROPBEAR_SSHD_DIR) dropbearmulti
+               PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" \
+               MULTI=1 SCPPROGRESS=1 -C $(DROPBEAR_SSHD_DIR)
 
 $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY)
        #$(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
@@ -59,6 +60,8 @@ $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SS
        install -d -m 755 $(TARGET_DIR)/usr/bin
        install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
                $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
+       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/scp
+       ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/ssh
        ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
        ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
        cp $(DROPBEAR_SSHD_DIR)/S50dropbear $(TARGET_DIR)/etc/init.d/