mediastreamer: fix build with libX11 and sdl without x11 support
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Jul 2012 09:49:19 +0000 (11:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Jul 2012 07:26:42 +0000 (09:26 +0200)
Fixes http://autobuild.buildroot.net/results/a8f2db4a40c0f53c0d25b2632fe87c2ce136f770

Mediastreamer assumes SDL has X11 support if SDL and libX11 are found,
which is not necessarily true in BR.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mediastreamer/mediastreamer.mk

index 9e67ed49d3697ea8694a5bee7c5d5894f77b0449..1f4e1d4eeb540a0a047c87028a471d7319174a25 100644 (file)
@@ -48,9 +48,10 @@ else
 MEDIASTREAMER_CONF_OPT += --disable-sdl
 endif
 
-ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
+# mediastreamer assumes SDL has X11 support if --enable-x11 (and X11 support
+# is only used for SDL output)
+ifeq ($(BR2_PACKAGE_SDL_X11),y)
 MEDIASTREAMER_CONF_OPT += --enable-x11
-MEDIASTREAMER_DEPENDENCIES += xlib_libX11
 else
 MEDIASTREAMER_CONF_OPT += --disable-x11
 endif