package/gumbo-parser: new package
authorRaphaël Mélotte <raphael.melotte@mind.be>
Wed, 30 Jun 2021 23:47:14 +0000 (01:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 20 Jul 2021 21:34:19 +0000 (23:34 +0200)
Gumbo is an implementation of the HTML5 parsing algorithm implemented
as a pure C99 library with no outside dependencies.

Signed-off-by: Raphaël Mélotte <raphael.melotte@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/gumbo-parser/Config.in [new file with mode: 0644]
package/gumbo-parser/gumbo-parser.hash [new file with mode: 0644]
package/gumbo-parser/gumbo-parser.mk [new file with mode: 0644]

index 1e1a30bac9eeb14b7134c29ac415fe70caf8a644..e77ceb2a9584a03c3ec702a434e677d970f866c0 100644 (file)
@@ -2255,6 +2255,7 @@ N:        Ramon Fried <rfried.dev@gmail.com>
 F:     package/bitwise/
 
 N:     Raphaël Mélotte <raphael.melotte@mind.be>
+F:     package/gumbo-parser/
 F:     package/jbig2dec/
 F:     package/mupdf/
 F:     package/python-boto3/
index de9378e11c7ee99903d3a98ae64c7de36776c1b9..95ad1a29f7559955cf90da1bc689a47a776baf5c 100644 (file)
@@ -1903,6 +1903,7 @@ menu "Other"
        source "package/gobject-introspection/Config.in"
        source "package/gsl/Config.in"
        source "package/gtest/Config.in"
+       source "package/gumbo-parser/Config.in"
        source "package/jemalloc/Config.in"
        source "package/lapack/Config.in"
        source "package/libabseil-cpp/Config.in"
diff --git a/package/gumbo-parser/Config.in b/package/gumbo-parser/Config.in
new file mode 100644 (file)
index 0000000..04bb229
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_GUMBO_PARSER
+       bool "gumbo-parser"
+       help
+         Gumbo is an implementation of the HTML5 parsing algorithm
+         implemented as a pure C99 library with no outside
+         dependencies. It's designed to serve as a building block for
+         other tools and libraries such as linters, validators,
+         templating languages, and refactoring and analysis tools.
+
+         https://github.com/google/gumbo-parser
diff --git a/package/gumbo-parser/gumbo-parser.hash b/package/gumbo-parser/gumbo-parser.hash
new file mode 100644 (file)
index 0000000..c4af330
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally computed:
+sha256  28463053d44a5dfbc4b77bcf49c8cee119338ffa636cc17fc3378421d714efad  gumbo-parser-0.10.1.tar.gz
+
+# Hash for license files:
+sha256  c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4  COPYING
diff --git a/package/gumbo-parser/gumbo-parser.mk b/package/gumbo-parser/gumbo-parser.mk
new file mode 100644 (file)
index 0000000..aedc56c
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# gumbo-parser
+#
+################################################################################
+
+GUMBO_PARSER_VERSION = 0.10.1
+GUMBO_PARSER_SITE = $(call github,google,gumbo-parser,v$(GUMBO_PARSER_VERSION))
+GUMBO_PARSER_LICENSE = Apache-2.0
+GUMBO_PARSER_LICENSE_FILES = COPYING
+GUMBO_PARSER_INSTALL_STAGING = YES
+GUMBO_PARSER_AUTORECONF = YES
+
+$(eval $(autotools-package))