package/ffmpeg: bump version to 3.4.1
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 18 Dec 2017 06:29:10 +0000 (07:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 18 Dec 2017 09:28:12 +0000 (10:28 +0100)
Configure options for libnut & libschroedinger were removed:
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=a3deeaade32db5a1b736b8d3365e52254f3fa6ac
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=220b24c7c97dc033ceab1510549f66d0e7b52ef1

Upstream now prefers NASM assembler over YASM:
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=4f9297ac3b39098547863d28fbc8d2a906d5be49

Added configure options for alsa support:
http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=b447629093d75f18d0a8fc44ec768022322b2182

Added configure options for libiconv:
http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=fe9c85e4e2650dc9537b54b1eabb4f9be7b628ed

Added license hashes.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ffmpeg/ffmpeg.hash
package/ffmpeg/ffmpeg.mk

index e986de98ca0c1dc9cfb3e9b6cbab4f6aecd54610..cdf740834be2696b5be1556a197cfd4149687d1b 100644 (file)
@@ -1,2 +1,5 @@
 # Locally calculated
-sha256 a893490c3a8a7caaa9c47373b789c0335d0ac3572f2ba61059de842b9e45d802  ffmpeg-3.3.5.tar.xz
+sha256 5a77278a63741efa74e26bf197b9bb09ac6381b9757391b922407210f0f991c0  ffmpeg-3.4.1.tar.xz
+sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING.GPLv2
+sha256 b634ab5640e258563c536e658cad87080553df6f34f62269a21d554844e58bfe  COPYING.LGPLv2.1
+sha256 73d99bc83313fff665b426d6672b4e0479102bc402fe22314ac9ce94a38aa5ff  LICENSE.md
index 3ac204f95e6525e8630c54606cb92a383a625b4d..5bb5d1e30e8d54328a5317e250aad235d8f11847 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-FFMPEG_VERSION = 3.3.5
+FFMPEG_VERSION = 3.4.1
 FFMPEG_SOURCE = ffmpeg-$(FFMPEG_VERSION).tar.xz
 FFMPEG_SITE = http://ffmpeg.org/releases
 FFMPEG_INSTALL_STAGING = YES
@@ -53,14 +53,12 @@ FFMPEG_CONF_OPTS = \
        --disable-libdc1394 \
        --disable-libgsm \
        --disable-libilbc \
-       --disable-libnut \
        --disable-libopenjpeg \
-       --disable-libschroedinger \
        --disable-libvo-amrwbenc \
        --disable-symver \
        --disable-doc
 
-FFMPEG_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv) host-pkgconf
+FFMPEG_DEPENDENCIES += host-pkgconf
 
 ifeq ($(BR2_PACKAGE_FFMPEG_GPL),y)
 FFMPEG_CONF_OPTS += --enable-gpl
@@ -161,7 +159,10 @@ endif
 ifeq ($(BR2_PACKAGE_FFMPEG_INDEVS),y)
 FFMPEG_CONF_OPTS += --enable-indevs
 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+FFMPEG_CONF_OPTS += --enable-alsa
 FFMPEG_DEPENDENCIES += alsa-lib
+else
+FFMPEG_CONF_OPTS += --disable-alsa
 endif
 else
 FFMPEG_CONF_OPTS += --disable-indevs
@@ -344,6 +345,13 @@ else
 FFMPEG_CONF_OPTS += --disable-libwavpack
 endif
 
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+FFMPEG_CONF_OPTS += --enable-iconv
+FFMPEG_DEPENDENCIES += libiconv
+else
+FFMPEG_CONF_OPTS += --disable-iconv
+endif
+
 # ffmpeg freetype support require fenv.h which is only
 # available/working on glibc.
 # The microblaze variant doesn't provide the needed exceptions
@@ -376,10 +384,10 @@ FFMPEG_CONF_OPTS += --disable-libx265
 endif
 
 ifeq ($(BR2_X86_CPU_HAS_MMX),y)
-FFMPEG_CONF_OPTS += --enable-yasm
-FFMPEG_DEPENDENCIES += host-yasm
+FFMPEG_CONF_OPTS += --enable-x86asm
+FFMPEG_DEPENDENCIES += host-nasm
 else
-FFMPEG_CONF_OPTS += --disable-yasm
+FFMPEG_CONF_OPTS += --disable-x86asm
 FFMPEG_CONF_OPTS += --disable-mmx
 endif