core/pkg-virtual: do not check they are neabled
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 29 Dec 2015 23:10:40 +0000 (00:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Dec 2015 09:01:30 +0000 (10:01 +0100)
Virtual packages do not have a Kconfig symbol, so we must not check that
they are enabled.

Fixes:
    http://autobuild.buildroot.org/results/287/28713478cc6edf8e5d5c3e830fee86a42f0afa8d/
    ... and numerous similar failures ...

[Thomas:
 - use "$($(PKG)_IS_VIRTUAL)" != "YES" instead of !
   "$($(PKG)_IS_VIRTUAL)" = "YES"]

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk
package/pkg-virtual.mk

index 2daf33780a6d3ae2ca004b2d705ef94e458db02a..9e884235b02c4583a2ab466f0c1e479d209600ef 100644 (file)
@@ -186,7 +186,10 @@ $(BUILD_DIR)/%/.stamp_configured:
 # building a package, even if not enabled in the configuration, we
 # want to accept it.
 ifeq ($(MAKECMDGOALS),)
-       @if test "$($(PKG)_TYPE)" = "target" -a -z "$($($(PKG)_KCONFIG_VAR))" ; then \
+       @if test "$($(PKG)_TYPE)" = "target" \
+               -a "$($(PKG)_IS_VIRTUAL)" != "YES" \
+               -a -z "$($($(PKG)_KCONFIG_VAR))" ; \
+       then \
                echo "ERROR: $($(PKG)_NAME) is in the dependency chain of a package that has" ; \
                echo "added it to its _DEPENDENCIES variable (directly or indirectly)" ; \
                echo "without selecting it from Config.in." ; \
index 9c68b511c4f949328ab7e12d84b23781d96c56ec..244c1d0420330180f954c9bd8c9461abd71f58ec 100644 (file)
@@ -41,6 +41,8 @@ $$(error No implementation selected for virtual package $(1). Configuration erro
 endif
 endif
 
+$(2)_IS_VIRTUAL = YES
+
 # A virtual package does not have any source associated
 $(2)_SOURCE =