mutt: fix build with BR2_PACKAGE_SKELETON_NONE
authorBaruch Siach <baruch@tkos.co.il>
Mon, 7 Aug 2017 17:54:14 +0000 (20:54 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 8 Aug 2017 15:11:20 +0000 (17:11 +0200)
BR2_PACKAGE_SKELETON_NONE does not provide the /var subdirectory which
breaks symlink creation in that directory. Make sure that /var exists
before creating the symlink.

Fixes:
http://autobuild.buildroot.net/results/32d/32dff0df759baf1120e4f11335e735eb0708b237/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/mutt/mutt.mk

index abd40e5dd612977a8d9fbccea962d7d5875cc746..b0bf5a7b413fdafd512e23f741e53db81239aef6 100644 (file)
@@ -66,6 +66,7 @@ MUTT_CONF_ENV += \
 MUTT_CONF_OPTS += --with-mailpath=/var/mail
 
 define MUTT_VAR_MAIL
+       mkdir -p $(TARGET_DIR)/var
        ln -sf /tmp $(TARGET_DIR)/var/mail
 endef
 MUTT_POST_INSTALL_TARGET_HOOKS += MUTT_VAR_MAIL