manual: do not generate .pyc files
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 5 Dec 2013 23:41:57 +0000 (00:41 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 14:23:26 +0000 (15:23 +0100)
Python saves a pre-compiled support/scripts/kconfiglib.pyc file
side-to-side with the corresponding .py file.

This does not work if the Buildroot source tree is read-only (but
this is not an error for Python, which keep going OK).

But this may cause issues for out-of-tree builds in case the same
Buildroot source tree is shared by many builds.

Also, 'make clean' currently does not clean this file, and out-of-tree
builds can remove it either, at the risk of causing issues for other
out-of-tree builds running at the same time.

Just tell Python not to generate .pyc files:
  - call the script via python, don't use the sha-bang
  - thus, make the script non-executable, and remove the sha-bang

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
docs/manual/manual.mk
support/scripts/gen-manual-lists.py [changed mode: 0755->0644]

index 09265665a24b3875c03aa110d36b7cf04fe4c7f1..f0bbff8e26aab26481075dd3f4580d8f2d058e21 100644 (file)
@@ -1,7 +1,7 @@
 manual-update-lists: manual-check-dependencies-lists
        $(Q)$(call MESSAGE,"Updating the manual lists...")
        $(Q)BR2_DEFCONFIG="" TOPDIR=$(TOPDIR) O=$(O)/docs/manual/.build \
-               $(TOPDIR)/support/scripts/gen-manual-lists.py
+               python -B $(TOPDIR)/support/scripts/gen-manual-lists.py
 
 # we can't use suitable-host-package here because that's not available in
 # the context of 'make release'
old mode 100755 (executable)
new mode 100644 (file)
index 4546e07..4562d7e
@@ -1,5 +1,3 @@
-#!/usr/bin/env python
-##
 ## gen-manual-lists.py
 ##
 ## This script generates the following Buildroot manual appendices: