nginx: fix nginx.old clean-up
authorDanomi Manchego <danomimanchego123@gmail.com>
Thu, 25 Jun 2015 03:32:49 +0000 (23:32 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jun 2015 21:00:57 +0000 (23:00 +0200)
The bin path for nginx is configured for /usr/sbin, so deleting
the nginx.old back-up from /usr/bin never works.  Fix path, and
also use "$(RM)" instead of "-$(RM)", as "rm -f" never fails.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Acked-by: Samuel Martin <s.martin49@gmail.com>
Tested-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nginx/nginx.mk

index 90ebbcc9895fbf60ab2b404e2e57d655cbb28ae6..502bc44fe39f06ab776be8c22df47c564d7bcfdc 100644 (file)
@@ -222,7 +222,7 @@ endef
 
 define NGINX_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
-       -$(RM) $(TARGET_DIR)/usr/bin/nginx.old
+       $(RM) $(TARGET_DIR)/usr/sbin/nginx.old
        $(INSTALL) -D -m 0664 package/nginx/nginx.logrotate \
                $(TARGET_DIR)/etc/logrotate.d/nginx
 endef