snort: avoid detecting the host pcre
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 07:12:26 +0000 (09:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 07:16:22 +0000 (09:16 +0200)
The pcre configure script does this:

if test "x$with_libpcre_libraries" != "xno"; then
    LDFLAGS="${LDFLAGS}  -L${with_libpcre_libraries}"
else
    LDFLAGS="${LDFLAGS} `pcre-config --libs`"
fi

So if you don't pass --with-libpcre-libraries, it calls pcre-config as
available in the PATH. So it picks up pcre-config from $(HOST_DIR) or
the system, which return results inappropriate for cross-compilation.

So, let's explicitly pass --with-libpcre-includes and
--with-libpcre-libraries to avoid those issues.

Fixes:

  http://autobuild.buildroot.net/results/3df11c48c8e2f795f478d1ee666dda9de19133d0/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/snort/snort.mk

index 13f16b3b0f4d45f6fa87688b5de78e3daca6d8ce..568393468bb626b6ada0235bcbc8bc4c10e4a9a6 100644 (file)
@@ -15,6 +15,8 @@ SNORT_DEPENDENCIES = libpcap libdnet daq pcre
 SNORT_AUTORECONF = YES
 
 SNORT_CONF_OPTS = \
+       --with-libpcre-includes=$(STAGING_DIR)/usr/include \
+       --with-libpcre-libraries=$(STAGING_DIR)/usr/lib \
        --with-libpcap-includes=$(STAGING_DIR)/usr/include/pcap \
        --disable-static-daq