package/busybox: invert dependency with tar
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 8 Jul 2018 09:45:35 +0000 (11:45 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 8 Jul 2018 10:22:14 +0000 (12:22 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/busybox/busybox.mk
package/tar/tar.mk

index 270dcc1416e4b16aa30089570559a37915784f52..ff2e4c770cbe845f7e573490d34e17875ecc8c55 100644 (file)
@@ -22,6 +22,7 @@ BUSYBOX_LDFLAGS = \
 
 # Packages that provide commands that may also be busybox applets:
 BUSYBOX_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_TAR),tar) \
        $(if $(BR2_PACKAGE_TFTPD),tftpd) \
        $(if $(BR2_PACKAGE_TRACEROUTE),traceroute) \
        $(if $(BR2_PACKAGE_UNZIP),unzip) \
index 9942e7773776470e222826b559f08425fe28bc85..6f609d7a022296c9da085ee868191b888725e726 100644 (file)
@@ -8,16 +8,11 @@ TAR_VERSION = 1.29
 TAR_SOURCE = tar-$(TAR_VERSION).tar.xz
 TAR_SITE = $(BR2_GNU_MIRROR)/tar
 # busybox installs in /bin, so we need tar to install as well in /bin
-# so that it overrides the Busybox symlinks.
+# so that we don't end up with two different tar
 TAR_CONF_OPTS = --exec-prefix=/
 TAR_LICENSE = GPL-3.0+
 TAR_LICENSE_FILES = COPYING
 
-# Prefer full-blown tar over buybox's version
-ifeq ($(BR2_PACKAGE_BUSYBOX),y)
-TAR_DEPENDENCIES += busybox
-endif
-
 ifeq ($(BR2_PACKAGE_ACL),y)
 TAR_DEPENDENCIES += acl
 TAR_CONF_OPTS += --with-posix-acls