flann: Disable find package for HDF5
authorJohan Oudinet <johan.oudinet@gmail.com>
Wed, 6 Dec 2017 14:47:53 +0000 (15:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Dec 2017 22:46:44 +0000 (23:46 +0100)
The HDF5 package is used by flann for testing purpose only and is
not part of buildroot packages. However, if present in the host, it will
be used and trigger the unsafe header/library path used in
cross-compilation error.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/flann/flann.mk

index e777fd8b2eee4f7fd8a2ec2b45e62b0d110b9b64..ef61815bbabfb3973cee279e9b38429c5bcc22a8 100644 (file)
@@ -15,6 +15,7 @@ FLANN_CONF_OPTS = \
        -DBUILD_MATLAB_BINDINGS=OFF \
        -DBUILD_EXAMPLES=$(if $(BR2_PACKAGE_FLANN_EXAMPLES),ON,OFF) \
        -DUSE_OPENMP=$(if $(BR2_GCC_ENABLE_OPENMP),ON,OFF) \
-       -DPYTHON_EXECUTABLE=OFF
+       -DPYTHON_EXECUTABLE=OFF \
+       -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=TRUE
 
 $(eval $(cmake-package))