Over-ride the target-install target rather than installing as a post-build
authorHamish Moffatt <hamish@cloud.net.au>
Mon, 8 Dec 2008 04:41:19 +0000 (04:41 -0000)
committerHamish Moffatt <hamish@cloud.net.au>
Mon, 8 Dec 2008 04:41:19 +0000 (04:41 -0000)
hook. Otherwise the wrong stamps are used and the library won't be reinstalled
if you clean out $(TARGET_DIR).

package/tiff/tiff.mk

index e7079e2179e6bbbe2065c8e70dcb9d38828daccf..fcca73b5b9200d79a222069ab1a606efd3c4d11c 100644 (file)
@@ -8,7 +8,7 @@ TIFF_SITE:=ftp://ftp.remotesensing.org/pub/libtiff
 TIFF_SOURCE:=tiff-$(TIFF_VERSION).tar.gz
 TIFF_LIBTOOL_PATCH = NO
 TIFF_INSTALL_STAGING = YES
-TIFF_INSTALL_TARGET = NO
+TIFF_INSTALL_TARGET = YES
 TIFF_CONF_OPT = \
        --enable-shared \
        --enable-static \
@@ -19,7 +19,7 @@ TIFF_DEPENDENCIES = uclibc pkgconfig zlib jpeg
 
 $(eval $(call AUTOTARGETS,package,tiff))
 
-$(TIFF_HOOK_POST_BUILD):
+$(TIFF_TARGET_INSTALL_TARGET):
        -cp -a $(TIFF_DIR)/libtiff/.libs/libtiff.so* $(TARGET_DIR)/usr/lib/
        $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libtiff.so
        touch $@