libupnpp: fix static linking issue with libcurl
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 14 May 2015 20:44:06 +0000 (22:44 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 14 May 2015 20:44:06 +0000 (22:44 +0200)
Fixes:
http://autobuild.buildroot.net/results/f38/f383bf4d7572a7dd59d382cd06a9baeb37e9161c/
http://autobuild.buildroot.net/results/d93/d934871d1b192706cd9163715c5ebcd96deff2b8/

Libcurl optionally links to a number of libraries that have to be taken into
consideration when linking statically.

Use pkg-config to get the correct libcurl link line, and also use it for
libupnp instead of the hardcoded list.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libupnpp/libupnpp.mk

index 853a7244ea3420f2398ab3083f3389ec5489f70a..defc16aefff9166b1ce9c3b718e0fe6c68cc00c8 100644 (file)
@@ -12,9 +12,11 @@ LIBUPNPP_INSTALL_STAGING = YES
 LIBUPNPP_DEPENDENCIES = expat libcurl libupnp
 
 # configure script fails to link against the dependencies of libupnp
-# causing upnp detection to fail when statically linking
+# and libcurl causing detection to fail when statically linking
 ifeq ($(BR2_STATIC_LIBS),y)
-LIBUPNPP_CONF_ENV += LIBS='-lthreadutil -lixml -pthread'
+LIBUPNPP_DEPENDENCIES += host-pkgconf
+LIBUPNPP_CONF_ENV += \
+       LIBS='$(shell $(PKG_CONFIG_HOST_BINARY) --libs libupnp libcurl)'
 endif
 
 $(eval $(autotools-package))