portmap: improve installation of binaries
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:17:57 +0000 (15:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 21:44:35 +0000 (22:44 +0100)
This commit explicits the permissions with which executables are
installed, and also makes sure that the build is aborted if one of the
binaries cannot be installed, instead of silently ignoring the error.

[Peter: fixop typos in commit message as noted by Yann]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/portmap/portmap.mk

index a41044318c1ad40975fabe1cd7310569483bab9c..5caf54cb2163cfd9d2bf84747f23ecb127af64c9 100644 (file)
@@ -22,7 +22,7 @@ endef
 
 define PORTMAP_INSTALL_TARGET_CMDS
        for sbin in $(PORTMAP_SBINS); do \
-               $(INSTALL) -D $(@D)/$$sbin $(TARGET_DIR)/sbin/$$sbin; \
+               $(INSTALL) -D -m 0755 $(@D)/$$sbin $(TARGET_DIR)/sbin/$$sbin || exit 1; \
        done
 endef