package/linux-firmware: add rpi settings files
authorFrank Hunleth <fhunleth@troodon-software.com>
Sat, 17 Oct 2020 15:18:48 +0000 (11:18 -0400)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 17 Oct 2020 16:13:25 +0000 (18:13 +0200)
The brcmfmac drivers now load settings files for BCM434xx devices and
fail if they're missing on the Raspberry Pi:

brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt failed with error -2

This commit copies the missing settings files over to the firmware
directory with the other files.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/linux-firmware/linux-firmware.mk

index 8a44129102d5ba9699172ac03726954b3e5c6c8f..e2a6ebcbf13271d5432467658798c0905ac862f0 100644 (file)
@@ -547,7 +547,10 @@ LINUX_FIRMWARE_FILES += \
        brcm/brcmfmac43362-sdio.bin brcm/brcmfmac43430-sdio.bin \
        brcm/brcmfmac43430a0-sdio.bin brcm/brcmfmac43455-sdio.bin \
        brcm/brcmfmac43569.bin brcm/brcmfmac43570-pcie.bin \
-       brcm/brcmfmac43602-pcie.ap.bin brcm/brcmfmac43602-pcie.bin
+       brcm/brcmfmac43602-pcie.ap.bin brcm/brcmfmac43602-pcie.bin \
+       brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt \
+       brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt \
+       brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.broadcom_bcm43xx
 endif