package/wpewebkit: disable JSC JIT for MIPSr6
authorAdrian Perez de Castro <aperez@igalia.com>
Tue, 11 Feb 2020 20:44:45 +0000 (22:44 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Feb 2020 22:33:52 +0000 (23:33 +0100)
Forcibly disable the JavaScriptCore JIT compilation support
for MIPSr6 processors, which are unsupported.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wpewebkit/wpewebkit.mk

index cf45b689432d449bd7d799b2147d1257a0166a27..8b890301b74900f9f1013baf64e0cfe2a1c11cc8 100644 (file)
@@ -63,4 +63,13 @@ else
 WPEWEBKIT_CONF_OPTS += -DUSE_WOFF2=OFF
 endif
 
+# JIT is not supported for MIPS r6, but the WebKit build system does not
+# have a check for these processors. Disable JIT forcibly here and use
+# the CLoop interpreter instead.
+#
+# Upstream bug: https://bugs.webkit.org/show_bug.cgi?id=191258
+ifeq ($(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
+WPEWEBKIT_CONF_OPTS += -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON
+endif
+
 $(eval $(cmake-package))