package/ffmpeg: fix typo "--enable-bsfs" -> "--enable-bsf"
authorAnatoly Borodin <anatoly.borodin@gmail.com>
Thu, 12 Mar 2020 19:45:17 +0000 (20:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 14 Mar 2020 14:28:31 +0000 (15:28 +0100)
Fix ffmpeg configuration when BR2_PACKAGE_FFMPEG_BSFS is not default ("all"):

Unknown option "--enable-bsfs=h264_metadata".
See ./configure --help for available options.
package/pkg-generic.mk:254: recipe for target '/root/buildroot/output/build/ffmpeg-4.2.2/.stamp_configured' failed

The option is named according to the scheme "--enable-SINGULAR=..." /
"--disable-PLURAL".

The typo is present since the release 2014.02:

https://git.buildroot.net/buildroot/commit/package/ffmpeg/ffmpeg.mk?id=62ab07ef769bd6504fe1db144aaac3fd45db9dad

Signed-off-by: Anatoly Borodin <anatoly.borodin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ffmpeg/ffmpeg.mk

index f0047c4e3b134decede0db86b5dba6400be316be..b7148bbba2dcb31c78a109ac5e9c6bf7fdcf243c 100644 (file)
@@ -135,7 +135,7 @@ endif
 
 ifneq ($(call qstrip,$(BR2_PACKAGE_FFMPEG_BSFS)),all)
 FFMPEG_CONF_OPTS += --disable-bsfs \
-       $(foreach x,$(call qstrip,$(BR2_PACKAGE_FFMPEG_BSFS)),--enable-bsfs=$(x))
+       $(foreach x,$(call qstrip,$(BR2_PACKAGE_FFMPEG_BSFS)),--enable-bsf=$(x))
 endif
 
 ifneq ($(call qstrip,$(BR2_PACKAGE_FFMPEG_PROTOCOLS)),all)