package/rauc: package/rauc: bump version to 1.5.1
authorBartosz Bilas <b.bilas@grinn-global.com>
Sat, 6 Feb 2021 18:53:24 +0000 (19:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 7 Feb 2021 09:21:34 +0000 (10:21 +0100)
Removed patch applied upstream.

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rauc/0001-src-mount.c-fix-build-with-kernel-4.14.patch [deleted file]
package/rauc/rauc.hash
package/rauc/rauc.mk

diff --git a/package/rauc/0001-src-mount.c-fix-build-with-kernel-4.14.patch b/package/rauc/0001-src-mount.c-fix-build-with-kernel-4.14.patch
deleted file mode 100644 (file)
index 9604e88..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From f73eefdbc0577b125f7d36f54a27d8e95af831dd Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Tue, 22 Dec 2020 11:52:31 +0100
-Subject: [PATCH] src/mount.c: fix build with kernel < 4.14
-
-Build with kernel headers < 4.14 fails since version 1.5.0 and
-https://github.com/rauc/rauc/commit/527bf2f7f746e0253f7843542e19cb0fa0c7c869:
-
-src/mount.c: In function 'r_setup_loop':
-src/mount.c:201:25: error: 'LOOP_SET_BLOCK_SIZE' undeclared (first use in this function)
-  looprc = ioctl(loopfd, LOOP_SET_BLOCK_SIZE, 4096);
-                         ^
-
-Indeed, LOOP_SET_BLOCK_SIZE is only defined since
-https://github.com/torvalds/linux/commit/89e4fdecb51cf5535867026274bc97de9480ade5
-
-Fixes:
- - http://autobuild.buildroot.org/results/829ae7ed66686c11a941ac99bd08a06f754affb4
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/rauc/rauc/pull/673]
----
- src/mount.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/mount.c b/src/mount.c
-index 2e593ca..75acf49 100644
---- a/src/mount.c
-+++ b/src/mount.c
-@@ -11,6 +11,10 @@
- #include "mount.h"
- #include "utils.h"
-+#ifndef LOOP_SET_BLOCK_SIZE
-+#define LOOP_SET_BLOCK_SIZE 0x4C09
-+#endif
-+
- gboolean r_mount_bundle(const gchar *source, const gchar *mountpoint, GError **error)
- {
-       const unsigned long flags = MS_NODEV | MS_NOSUID | MS_RDONLY;
--- 
-2.29.2
-
index 73c1add995fd66d9c2cb48a47589bc1352bcd208..a02525784505a052aa07c7230401b9dfb41f8802 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated, after verifying against
-# https://github.com/rauc/rauc/releases/download/v1.5/rauc-1.5.tar.xz.asc
-sha256  5dfbc46e808240c5014d318cfe64f0431307c37aa79cb2b013caa12daaf96d9d  rauc-1.5.tar.xz
+# https://github.com/rauc/rauc/releases/download/v1.5.1/rauc-1.5.1.tar.xz.asc
+sha256  d4ea009ce702bcb083d942398ccfedec959c6bbb7adc0fd77ae9314ce11d9d91  rauc-1.5.1.tar.xz
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
index 51087e9f36b201392dc992a03f1e29b34d6b6df1..4fb3ddde3e3dd26fe9f08d418c8745272479071a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-RAUC_VERSION = 1.5
+RAUC_VERSION = 1.5.1
 RAUC_SITE = https://github.com/rauc/rauc/releases/download/v$(RAUC_VERSION)
 RAUC_SOURCE = rauc-$(RAUC_VERSION).tar.xz
 RAUC_LICENSE = LGPL-2.1