package/freerdp: fix dependency on walyand
authorAdam Duskett <aduskett@gmail.com>
Sat, 25 Nov 2017 19:33:05 +0000 (14:33 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Nov 2017 13:04:05 +0000 (14:04 +0100)
Currently, wayland support is enabled when the wayland package is
enabled, not when the FreeRDP wayland client is enabled.

But the dependency on libxkbcomon is only enforced from Config.in
when the FreeRDP wayland client is enabled., but is added to build
dependencies when the wayland package is enabled.

As such, we can end up in a situation where the FreeRDP wayland
client is disabled, the wayland package is enabled, and the
libxkbcommon package is also disabled, which casues the build to
fail with:

    Makefile:539: *** libxkbcommon is in the dependency chain of
    freerdp that has added it to its _DEPENDENCIES variable without
    selecting it or depending on it from Config.in.  Stop.

Change the build dependency to actually be on the FreeRDP client
being enabled.

Fixes;
    http://autobuild.buildroot.net/results/dc3e11f7076a8355f3d2f9cb49c6325dcf7084bd

Signed-off-by: Adam Duskett <Adamduskett@outlook.com>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freerdp/freerdp.mk

index 69a89a190cded8a5a7ec4f6ad4ca9030d9e01981..0ceef576a8f2e87674eb4dac94558c6ae3fdb3c3 100644 (file)
@@ -198,7 +198,7 @@ else
 FREERDP_CONF_OPTS += -DWITH_XV=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_WAYLAND),y)
+ifeq ($(BR2_PACKAGE_FREERDP_CLIENT_WL),y)
 FREERDP_DEPENDENCIES += wayland libxkbcommon
 FREERDP_CONF_OPTS += \
        -DWITH_WAYLAND=ON \