fetch/git: clone the repository as bare
authorJean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
Wed, 16 Mar 2011 16:07:08 +0000 (17:07 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 16 Mar 2011 21:46:52 +0000 (22:46 +0100)
This will reduce the space used and speed up the clone as it is only
used to generate an archive, which doesn't need the git working tree.

Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.package.in

index 84687d58ec073d0361ee494d0eec468db47e8fdd..bf4e1b49a37b1bb010dd9054e7fe9b39fbc132bb 100644 (file)
@@ -105,7 +105,7 @@ endif
 define DOWNLOAD_GIT
        test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
        (pushd $(DL_DIR) > /dev/null && \
-       $(GIT) clone $($(PKG)_SITE) $($(PKG)_BASE_NAME) && \
+       $(GIT) clone --bare $($(PKG)_SITE) $($(PKG)_BASE_NAME) && \
        pushd $($(PKG)_BASE_NAME) > /dev/null && \
        $(GIT) archive --format=tar --prefix=$($(PKG)_BASE_NAME)/ $($(PKG)_DL_VERSION) | \
                gzip -c > $(DL_DIR)/$($(PKG)_SOURCE) && \