package: add tree
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 Jun 2013 14:38:04 +0000 (16:38 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 Jun 2013 14:38:04 +0000 (16:38 +0200)
Tree is a recursive directory listing command that produces a depth
indented listing of files.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/tree/Config.in [new file with mode: 0644]
package/tree/tree.mk [new file with mode: 0644]

index f26b1aa85f65df8c2351ec1025f0f9c6d38a66f8..ce82e9964b078033c3aaf02e5e7e77916cd7f711 100644 (file)
@@ -95,6 +95,7 @@ source "package/sstrip/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/tar/Config.in"
 endif
+source "package/tree/Config.in"
 source "package/vala/Config.in"
 source "package/yasm/Config.in"
 endmenu
diff --git a/package/tree/Config.in b/package/tree/Config.in
new file mode 100644 (file)
index 0000000..b6e21c8
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_TREE
+       bool "tree"
+       depends on BR2_USE_WCHAR
+       help
+         Tree is a recursive directory listing command that produces
+         a depth indented listing of files, which is colorized ala
+         dircolors if the LS_COLORS environment variable is set and
+         output is to tty.
+
+         http://mama.indstate.edu/users/ice/tree/
+
+comment "tree requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
diff --git a/package/tree/tree.mk b/package/tree/tree.mk
new file mode 100644 (file)
index 0000000..509ba45
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# tree
+#
+################################################################################
+
+TREE_VERSION = 1.6.0
+TREE_SOURCE = tree-$(TREE_VERSION).tgz
+TREE_SITE = http://mama.indstate.edu/users/ice/tree/src/
+TREE_LICENSE = GPLv2+
+TREE_LICENSE_FILES = LICENSE
+
+define TREE_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define TREE_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/tree $(TARGET_DIR)/usr/bin/tree
+       $(INSTALL) -D -m 0644 $(@D)/doc/tree.1 \
+               $(TARGET_DIR)/usr/share/man/man1/tree.1
+endef
+
+define TREE_CLEAN_CMDS
+       -$(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))