package/boost: add boot-type_erasure support
authorRomain Naour <romain.naour@smile.fr>
Sat, 2 Jul 2016 15:29:52 +0000 (17:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 16:55:02 +0000 (18:55 +0200)
Until now this library wasn't handled by the Buildroot packaging,
so add a new config option to disable it when requested.

Also disable boost-type_erasure for the host variant to keep it as
minimal as possible.

Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/Config.in
package/boost/boost.mk

index 0cc9a589a9ef555f6d1bbc985fb7e02ffad6d93c..51d4ed713a657bb70fb491d222ffeb45a6be9485 100644 (file)
@@ -154,6 +154,9 @@ config BR2_PACKAGE_BOOST_THREAD
 config BR2_PACKAGE_BOOST_TIMER
        bool "boost-timer"
 
+config BR2_PACKAGE_BOOST_TYPE_ERASURE
+       bool "boost-type_erasure"
+
 config BR2_PACKAGE_BOOST_WAVE
        bool "boost-wave"
 
index fc8926509b4a50a5cdc00844bf5a43a972e10fbc..1d42f6c2a7b0e30c41abce3948ad7f38f35545a8 100644 (file)
@@ -18,7 +18,8 @@ HOST_BOOST_FLAGS = --without-icu \
        --without-libraries=$(subst $(space),$(comma),atomic chrono context \
        coroutine coroutine2 date_time exception filesystem graph \
        graph_parallel iostreams locale log math mpi program_options python \
-       random regex serialization signals system test thread timer wave)
+       random regex serialization signals system test thread timer type_erasure \
+       wave)
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
@@ -47,6 +48,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_SYSTEM),,system)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_TEST),,test)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_THREAD),,thread)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_TIMER),,timer)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_TYPE_ERASURE),,type_erasure)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_WAVE),,wave)
 
 BOOST_TARGET_CXXFLAGS = $(TARGET_CXXFLAGS)