git: needs zlib and host-gettext
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 3 Jun 2013 05:15:48 +0000 (05:15 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 Jun 2013 20:27:08 +0000 (22:27 +0200)
host-gettext fixes:
http://autobuild.buildroot.net/results/a5b/a5b1bb708d62a9e296f05899f0984087fcf9e2ce/

zlib fixes:
http://autobuild.buildroot.net/results/08f/08f5ed4dd35ad1ce06dda7577aae87b9aa7069b2/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/git/Config.in
package/git/git.mk

index 31e5ffe5d9ca14575c79bd1ab8727fde669ea4bc..dc342aa7bbaee7575c5ae6b09054af326cf9279e 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_GIT
        bool "git"
        depends on BR2_LARGEFILE
+       select BR2_PACKAGE_ZLIB
        help
          Git is a free and open source distributed version control system
          designed to handle everything from small to very large projects.
index 408456bc9d16daa0913a0898d4ce84a38c107fff..6bc9761493a364480541481c2c61b1786ba16d92 100644 (file)
@@ -8,10 +8,7 @@ GIT_VERSION         = 1.8.3
 GIT_SITE            = http://git-core.googlecode.com/files/
 GIT_LICENSE         = GPLv2 LGPLv2.1+
 GIT_LICENSE_FILES   = COPYING LGPL-2.1
-
-ifeq ($(BR2_PACKAGE_ZLIB),y)
-       GIT_DEPENDENCIES += zlib
-endif
+GIT_DEPENDENCIES    = zlib host-gettext
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
        GIT_DEPENDENCIES += openssl