pacakge/dieharder: fix autoreconf
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 1 Apr 2017 19:09:09 +0000 (21:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Apr 2017 20:03:58 +0000 (22:03 +0200)
When dieharder was committed, Thomas removed the hook to cleanup the m4
files, on the reason that autoreconf would recreate the broken symlinks
(and because the hook was too complex).

It turns out the hook was needed: if the symbolic links are
broken (libtool not installed on the host machine), autoreconf fails to
do its job.

Reinstate a simpler hook.

Fixes:
    http://autobuild.buildroot.org/results/a92/a92e9a74b0966f8f0bc4080f918d5ddf4c1ec0ce/
    http://autobuild.buildroot.org/results/a4f/a4f6647f69ad89ff1ffe5f1331281fb7a57ade4e/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Julien Viard de Galbert <julien@vdg.name>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dieharder/dieharder.mk

index 05ca25311f7827f9172865a5a846dce468888a03..c3eee6455389debe8c553b99dbc3032b900bd2e8 100644 (file)
@@ -15,13 +15,17 @@ DIEHARDER_DEPENDENCIES = gsl
 # The original configure does not use variables provided in the
 # environment so _CONF_ENV does not work. (_CONF_OPTS does).
 #
-# In addition, the m4/*.m4 files are symlinks to /usr/share, which
-# clearly doesn't work, so doing an autoreconf replaces them.
-#
 # Finally, we patch configure.ac and some Makefile.am so we need to
 # autoreconf anyway
 DIEHARDER_AUTORECONF = YES
 
+# The m4/*.m4 files are symlinks to /usr/share, which clearly doesn't
+# work, and doing an autoreconf does not replace them.
+define DIEHARDER_M4_CLEAN
+       rm -f $(@D)/m4/*.m4
+endef
+DIEHARDER_POST_PATCH_HOOKS += DIEHARDER_M4_CLEAN
+
 # fix endianness detection
 ifeq ($(BR2_ENDIAN),"BIG")
 DIEHARDER_CONF_ENV = ac_cv_c_endian=big