package/python-numpy: use lapack instead of clapack
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 25 Jul 2021 11:12:29 +0000 (13:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 26 Jul 2021 21:45:21 +0000 (23:45 +0200)
The clapack package is deprecated and will be removed. Use lapack
instead.

Cc: Jagan Teki <jagan@amarulasolutions.com>
Cc: Damien DUVAL <damien.duval@smile.fr>
Cc: Alexandre PAYEN <alexandre.payen@smile.fr>
Cc: Romain Naour <romain.naour@gmail.com>
Cc: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-numpy/python-numpy.mk

index 8260de7e5de8e58cd26e5e9429ab6d1129ad463c..72c6e0c9817748a541e36bdb37da1f46cf891227 100644 (file)
@@ -17,8 +17,8 @@ PYTHON_NUMPY_SETUP_TYPE = setuptools
 PYTHON_NUMPY_DEPENDENCIES = host-python-cython
 HOST_PYTHON_NUMPY_DEPENDENCIES = host-python-cython
 
-ifeq ($(BR2_PACKAGE_CLAPACK),y)
-PYTHON_NUMPY_DEPENDENCIES += clapack
+ifeq ($(BR2_PACKAGE_LAPACK),y)
+PYTHON_NUMPY_DEPENDENCIES += lapack
 else
 PYTHON_NUMPY_ENV += BLAS=None LAPACK=None
 endif