libtorrent: zlib is mandatory
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 5 Oct 2015 01:04:37 +0000 (22:04 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 5 Oct 2015 06:29:25 +0000 (08:29 +0200)
zlib isn't optional even though it seems like it, fixes build failure
such as:

log.cc:51:18: fatal error: zlib.h: No such file or directory

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libtorrent/Config.in
package/libtorrent/libtorrent.mk

index 48e6addef958c7c36c747edf27453959fd1cbfb4..17a1f232e7003d11967d86eec2514b22b5d73db1 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_LIBTORRENT
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_ARCH_HAS_ATOMICS
+       select BR2_PACKAGE_ZLIB
        help
          BitTorrent library written in C++ for *nix
 
index 633b86a869077cec150d120f1c5bdfb79403583a..ef1c75f03938cac7fb60ef4cdb79237b9e9174a8 100644 (file)
@@ -6,13 +6,12 @@
 
 LIBTORRENT_VERSION = 0.13.6
 LIBTORRENT_SITE = http://rtorrent.net/downloads
-LIBTORRENT_DEPENDENCIES = host-pkgconf \
-       $(if $(BR2_PACKAGE_OPENSSL),openssl) \
-       $(if $(BR2_PACKAGE_ZLIB),zlib)
+LIBTORRENT_DEPENDENCIES = host-pkgconf zlib \
+       $(if $(BR2_PACKAGE_OPENSSL),openssl)
 LIBTORRENT_CONF_OPTS = --enable-aligned \
        --disable-instrumentation \
-       $(if $(BR2_PACKAGE_OPENSSL),--enable-openssl,--disable-openssl) \
-       $(if $(BR2_PACKAGE_ZLIB),--with-zlib=$(STAGING_DIR)/usr,--without-zlib)
+       --with-zlib=$(STAGING_DIR)/usr \
+       $(if $(BR2_PACKAGE_OPENSSL),--enable-openssl,--disable-openssl)
 LIBTORRENT_INSTALL_STAGING = YES
 LIBTORRENT_AUTORECONF = YES
 LIBTORRENT_LICENSE = GPLv2