projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
768a0eb
)
prboom: fix static linking
author
Peter Korsgaard
<peter@korsgaard.com>
Sat, 13 Dec 2014 23:14:40 +0000
(
00:14
+0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Sat, 13 Dec 2014 23:14:40 +0000
(
00:14
+0100)
Fixes:
http://autobuild.buildroot.net/results/97b/
97bb50add010e44aca8fcb079d8df9270d3cae45
/
http://autobuild.buildroot.net/results/a96/
a969fd15a652df96c2414cf0c5f2e345d38e6e6c
/
http://autobuild.buildroot.net/results/9ba/
9ba92c01b2c6b6eae2dcda60c2b80d66d2002d4b
/
http://autobuild.buildroot.net/results/776/
776394ba89070ee2fa6e81585078df0a0e2ae3f2
/
And many more.
SDL_mixer uses symbols from SDL, but ends up after it on the link cmdline,
breaking static linking. Fix it by forcing the SDL libs at the very end.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/prboom/prboom.mk
patch
|
blob
|
history
diff --git
a/package/prboom/prboom.mk
b/package/prboom/prboom.mk
index c39b5a34abf7261e5edf1f1ff881bf2d5b87685e..7f9d6a0ba9e780be66b379e682a1733c3fd1da44 100644
(file)
--- a/
package/prboom/prboom.mk
+++ b/
package/prboom/prboom.mk
@@
-15,6
+15,12
@@
ifeq ($(BR2_PACKAGE_LIBPNG),y)
PRBOOM_DEPENDENCIES += libpng
endif
+ifeq ($(BR2_STATIC_LIBS),y)
+# SDL_mixer uses symbols from SDL, but ends up after it on the link
+# cmdline. Fix it by forcing the SDL libs at the very end
+PRBOOM_CONF_ENV += LIBS="$(shell $(STAGING_DIR)/usr/bin/sdl-config --static-libs)"
+endif
+
PRBOOM_CONF_OPTS = \
--oldincludedir=$(STAGING_DIR)/usr/include \
--with-sdl-prefix=$(STAGING_DIR)/usr \