package/schifra: remove package
authorRomain Naour <romain.naour@openwide.fr>
Sat, 3 Oct 2015 16:35:05 +0000 (18:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 16:40:48 +0000 (18:40 +0200)
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Cc: Arnaud RĂ©billout <rebillout@syscom.ch>
Cc: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/schifra/Config.in [deleted file]
package/schifra/schifra.hash [deleted file]
package/schifra/schifra.mk [deleted file]

index 9a59e73fe2992f089159304309cefdd039b53613..e031bed35fdf31fa3fd47a5fbcd6dc17bb795a07 100644 (file)
@@ -107,6 +107,12 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2015.11"
 
+config BR2_PACKAGE_SCHIFRA
+       bool "schifra package has been removed"
+       help
+         Schifra package has been maked broken since 2014.11 release and
+         haven't been fixed since then.
+
 config BR2_PACKAGE_ZXING
        bool "zxing option has been renamed"
        select BR2_LEGACY
index 4c8bb2183c40d20b15f8cb262bf5b98162473020..3794f44915798d31ab88ad67103e62e407604c44 100644 (file)
@@ -1136,7 +1136,6 @@ endif
        source "package/protobuf-c/Config.in"
        source "package/qhull/Config.in"
        source "package/qlibc/Config.in"
-       source "package/schifra/Config.in"
        source "package/startup-notification/Config.in"
        source "package/tz/Config.in"
        source "package/tzdata/Config.in"
diff --git a/package/schifra/Config.in b/package/schifra/Config.in
deleted file mode 100644 (file)
index a3f699a..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-config BR2_PACKAGE_SCHIFRA
-       bool "schifra"
-       depends on BR2_INSTALL_LIBSTDCPP
-       # Upstream keep changing the tarball without doing new
-       # releases. This is not acceptable for Buildroot, as
-       # reproducible builds are very important.
-       depends on BR2_BROKEN
-       help
-         Schifra is a very robust, highly optimized and extremely configurable
-         Reed-Solomon error correcting code library for both software and IP
-         core based applications with implementations in C++ and VHDL.
-
-         http://www.schifra.com/
-
-if BR2_PACKAGE_SCHIFRA
-
-config BR2_PACKAGE_SCHIFRA_EXAMPLES
-       bool "schifra examples"
-       help
-         Build and install the schifra example applications.
-
-endif
-
-comment "schifra needs a toolchain w/ C++"
-       depends on BR2_BROKEN
-       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/schifra/schifra.hash b/package/schifra/schifra.hash
deleted file mode 100644 (file)
index 7f8e6c0..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-# Calculated locally after download
-# Upstream doesn't store a version and tarball may change unexpectedly!
-sha256 3e60478cf024d87735d1cc1460aa2176c449e6c7f76914eefda25d3b20d22522        schifra.tgz
diff --git a/package/schifra/schifra.mk b/package/schifra/schifra.mk
deleted file mode 100644 (file)
index 661ef04..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-################################################################################
-#
-# schifra
-#
-################################################################################
-
-SCHIFRA_VERSION = 0.0.1
-SCHIFRA_SITE = http://www.schifra.com/downloads
-SCHIFRA_SOURCE = schifra.tgz
-SCHIFRA_INSTALL_STAGING = YES
-SCHIFRA_LICENSE = schifra license
-SCHIFRA_LICENSE_FILES = schifra_license.txt
-
-SCHIFRA_MAKE_OPTS = \
-       COMPILER="$(TARGET_CXX)" \
-       OPTIONS="$(TARGET_CFLAGS) $(TARGET_LDFLAGS)"
-
-# The examples are the only buildable artefacts.
-ifeq ($(BR2_PACKAGE_SCHIFRA_EXAMPLES),y)
-define SCHIFRA_BUILD_CMDS
-       $(MAKE) -C $(@D) $(SCHIFRA_MAKE_OPTS) all
-endef
-
-define SCHIFRA_INSTALL_EXAMPLES
-       cd $(@D) && for i in `find -type f -name 'schifra_*' -executable` ; \
-       do \
-               $(INSTALL) -m 0755 -D $$i $(TARGET_DIR)/usr/bin/$$i; \
-       done
-endef
-
-SCHIFRA_POST_INSTALL_TARGET_HOOKS += SCHIFRA_INSTALL_EXAMPLES
-endif
-
-define SCHIFRA_INSTALL_TARGET_CMDS
-       cd $(@D) && for i in schifra_*.hpp; do \
-               $(INSTALL) -m 0644 -D $$i $(TARGET_DIR)/usr/include/$$i; done
-endef
-
-define SCHIFRA_INSTALL_STAGING_CMDS
-       cd $(@D) && for i in schifra_*.hpp; do \
-               $(INSTALL) -m 0644 -D $$i $(STAGING_DIR)/usr/include/$$i; done
-endef
-
-$(eval $(generic-package))