barebox: add an option to embed environment image
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 6 May 2016 05:46:04 +0000 (07:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 6 May 2016 13:48:01 +0000 (15:48 +0200)
Barebox provides an option to embed a custom environment image into
barebox binary. This image will be used, when the environment found in
the environment sector is invalid. Both embedded and external images
can be used together, so having both options at the same time is
justified.

This patch sets barebox Kconfig option CONFIG_DEFAULT_ENVIRONMENT_PATH
to user specified path. This way one can use such BR's variables like
BR2_EXTERNAL, TOPDIR etc. to provide paths to custom environment
folders.

Cc: Pieter Smith <pieter@boesman.nl>
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/barebox/barebox-aux/Config.in
boot/barebox/barebox.mk
boot/barebox/barebox/Config.in

index 35aadc0e4abaab4bd9709b873310e8ebc587f139..315e1a3fcae2a6c65be66889acac556797831279 100644 (file)
@@ -57,3 +57,20 @@ config BR2_TARGET_BAREBOX_AUX_CUSTOM_ENV_PATH
          the additions needed. The output will be an image in the
          barebox devfs format, stored in the images directory, with
          the same name as the directory name given here.
+
+config BR2_TARGET_BAREBOX_AUX_CUSTOM_EMBEDDED_ENV_PATH
+       string "Embedded environment path"
+       help
+         If this option is not empty, it is the path to a custom
+         embedded barebox environment. This image will be used when
+         the environment found in the environment sector is
+         invalid. This option sets the barebox Kconfig option
+         CONFIG_DEFAULT_ENVIRONMENT_PATH to the specified path. This
+         way it is possible to use Buildroot variables like
+         BR2_EXTERNAL, TOPDIR etc. to refer to the custom
+         environment.
+
+         Depending on your setup, the custom embedded environment
+         will probably be based on either the content of the
+         defaultenv or defaultenv-2 directories in the barebox source
+         code.
index 949fb9fe386e0ea3835bbb6a34a12adb20bc96a3..832297eef6f73256daee54b52bfe827104558364 100644 (file)
@@ -39,6 +39,8 @@ $(1)_DEPENDENCIES = host-lzop
 $(1)_LICENSE = GPLv2 with exceptions
 $(1)_LICENSE_FILES = COPYING
 
+$(1)_CUSTOM_EMBEDDED_ENV_PATH = $$(call qstrip,$$(BR2_TARGET_$(1)_CUSTOM_EMBEDDED_ENV_PATH))
+
 ifneq ($$(call qstrip,$$(BR2_TARGET_BAREBOX_CUSTOM_PATCH_DIR)),)
 define $(1)_APPLY_CUSTOM_PATCHES
        $$(APPLY_PATCHES) $$(@D) \
@@ -96,6 +98,13 @@ define $(1)_INSTALL_CUSTOM_ENV
 endef
 endif
 
+ifneq ($$($(1)_CUSTOM_EMBEDDED_ENV_PATH),)
+define $(1)_KCONFIG_FIXUP_CMDS
+       $$(call KCONFIG_ENABLE_OPT,CONFIG_DEFAULT_ENVIRONMENT,$$(@D)/.config)
+       $$(call KCONFIG_SET_OPT,CONFIG_DEFAULT_ENVIRONMENT_PATH,"$$($(1)_CUSTOM_EMBEDDED_ENV_PATH)",$$(@D)/.config)
+endef
+endif
+
 define $(1)_BUILD_CMDS
        $$($(1)_BUILD_BAREBOXENV_CMDS)
        $$(TARGET_MAKE_ENV) $$(MAKE) $$($(1)_MAKE_FLAGS) -C $$(@D)
index bf13ea5ca3091b31e1d1c0c645234d46cc632342..f5e3bae8d5d4bb690caed6a37a561ae35d604ce0 100644 (file)
@@ -63,3 +63,20 @@ config BR2_TARGET_BAREBOX_CUSTOM_ENV_PATH
          the additions needed. The output will be an image in the
          barebox devfs format, stored in the images directory, with
          the same name as the directory name given here.
+
+config BR2_TARGET_BAREBOX_CUSTOM_EMBEDDED_ENV_PATH
+       string "Embedded environment path"
+       help
+         If this option is not empty, it is the path to a custom
+         embedded barebox environment. This image will be used when
+         the environment found in the environment sector is
+         invalid. This option sets the barebox Kconfig option
+         CONFIG_DEFAULT_ENVIRONMENT_PATH to the specified path. This
+         way it is possible to use Buildroot variables like
+         BR2_EXTERNAL, TOPDIR etc. to refer to the custom
+         environment.
+
+         Depending on your setup, the custom embedded environment
+         will probably be based on either the content of the
+         defaultenv or defaultenv-2 directories in the barebox source
+         code.