syslinux: add patch to disable pie
authorRyan Coe <bluemrp9@gmail.com>
Mon, 12 Sep 2016 01:04:26 +0000 (18:04 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 12 Sep 2016 20:32:47 +0000 (22:32 +0200)
Ubuntu 16.10 has pie enable by default. This causes a build failure with
syslinux.

https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1579023

Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
[Thomas: improve patch description.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/syslinux/0002-disable-pie.patch [new file with mode: 0644]

diff --git a/boot/syslinux/0002-disable-pie.patch b/boot/syslinux/0002-disable-pie.patch
new file mode 100644 (file)
index 0000000..b31b622
--- /dev/null
@@ -0,0 +1,22 @@
+Description: Disable PIE to avoid FTBFS on amd64
+Bug-Ubuntu: https://bugs.launchpad.net/bugs/1579023
+Author: Graham Inggs <ginggs@ubuntu.com>
+Last-Update: 2016-05-06
+
+gcc 6.x has PIE support enabled by default, which causes a build issue
+with syslinux. This patch disables PIE support in the relevant
+syslinux Makefile.
+
+Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
+
+--- a/gpxe/src/Makefile
++++ b/gpxe/src/Makefile
+@@ -4,7 +4,7 @@
+ #
+
+ CLEANUP               :=
+-CFLAGS                :=
++CFLAGS                := -fno-PIE
+ ASFLAGS               :=
+ LDFLAGS               :=
+ MAKEDEPS      := Makefile