mpg123: select sensible cpu optimization depending on arch/fpu
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 17 Dec 2009 21:08:57 +0000 (22:08 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 17 Dec 2009 21:10:40 +0000 (22:10 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/mpg123/mpg123.mk

index 25d5dd27917285dff2d38538915d9cf5970680f4..ea35220765bfe77a5fb09cf81f8abbd5aef7ec82 100644 (file)
@@ -7,7 +7,19 @@ MPG123_VERSION = 0.66
 MPG123_SOURCE = mpg123-$(MPG123_VERSION).tar.bz2
 MPG123_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/mpg123
 
-MPG123_CONF_OPT = --program-prefix='' --with-cpu=generic_nofpu
+MPG123_CPU = $(if $(BR2_SOFT_FLOAT),generic_nofpu,generic)
+
+ifeq ($(BR2_i386),y)
+MPG123_CPU = x86
+endif
+
+ifeq ($(BR2_powerpc),y)
+ifneq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),)
+MPG123_CPU = altivec
+endif
+endif
+
+MPG123_CONF_OPT = --program-prefix='' --with-cpu=$(MPG123_CPU)
 
 # Check if ALSA is built, then we should configure after alsa-lib so
 # ./configure can find alsa-lib.