package/rust: disable ninja
authorRomain Naour <romain.naour@gmail.com>
Wed, 17 Feb 2021 23:24:11 +0000 (00:24 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 20 Feb 2021 16:02:51 +0000 (17:02 +0100)
Ninja has recently be enabled as the default build system to build
llvm fork for rust compiler [1]. But we can still use Make if
"ninja = false" is provided in config.toml.

Ninja support can be enabled by a following patch.

[1] https://github.com/rust-lang/rust/commit/30b7dac745b1555cd96f41977f7d24435cbe7fa2

Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/1019386205

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/rust/rust.mk

index 798450e04eaa438c66d422960046418631c956fc..a38a3d64f55fadd19a3934cdf8a4fb3d75fa9a08 100644 (file)
@@ -65,6 +65,8 @@ define HOST_RUST_CONFIGURE_CMDS
                echo 'channel = "stable"'; \
                echo '[target.$(RUSTC_TARGET_NAME)]'; \
                echo 'cc = "$(TARGET_CROSS)gcc"'; \
+               echo '[llvm]'; \
+               echo 'ninja = false'; \
        ) > $(@D)/config.toml
 endef