package/aircrack-ng: add optional hwloc dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 30 Jan 2019 17:28:33 +0000 (18:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 2 Feb 2019 14:00:12 +0000 (15:00 +0100)
hwloc dependency has been added in version 1.4 with
https://github.com/aircrack-ng/aircrack-ng/commit/c31b27449962bc69638b32ec14e0ffdb8997dfcf

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/aircrack-ng/aircrack-ng.mk

index 350e251bfe11ed7d755640005732a8bc0517c62c..b51332ab77c43325676063521cdd9a10702718e2 100644 (file)
@@ -31,6 +31,13 @@ else
 AIRCRACK_NG_CONF_OPTS += --without-duma
 endif
 
+ifeq ($(BR2_PACKAGE_HWLOC),y)
+AIRCRACK_NG_DEPENDENCIES += hwloc
+AIRCRACK_NG_CONF_OPTS += --enable-hwloc
+else
+AIRCRACK_NG_CONF_OPTS += --disable-hwloc
+endif
+
 ifeq ($(BR2_PACKAGE_JEMALLOC),y)
 AIRCRACK_NG_DEPENDENCIES += jemalloc
 AIRCRACK_NG_CONF_OPTS += --with-jemalloc