mpd: switch smb support to samba4
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 6 Mar 2015 12:50:30 +0000 (09:50 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 12:31:05 +0000 (14:31 +0200)
samba3 is deprecated upstream.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 5c25445c13c93a8a670b807e4131fd53276f13a4..8ed11490fefc8850d56c57c9f3c95836d8892e32 100644 (file)
@@ -192,11 +192,14 @@ config BR2_PACKAGE_MPD_LIBNFS
 comment "nfs support needs a toolchain w/ RPC"
        depends on !BR2_TOOLCHAIN_HAS_NATIVE_RPC
 
+comment "samba support needs an (e)glibc toolchain"
+       depends on !BR2_TOOLCHAIN_USES_GLIBC
+
 config BR2_PACKAGE_MPD_LIBSMBCLIENT
        bool "samba"
        depends on !BR2_nios2 # samba
-       select BR2_PACKAGE_SAMBA
-       select BR2_PACKAGE_SAMBA_LIBSMBCLIENT
+       depends on BR2_TOOLCHAIN_USES_GLIBC
+       select BR2_PACKAGE_SAMBA4
        help
          Enable Samba support.
 
index 41f3564ca59e9a606a6141358df65cc38ad4db5e..b5adafd270f423d0cbb00799c368bdbfbf4cd90c 100644 (file)
@@ -114,7 +114,7 @@ MPD_CONF_OPTS += --disable-nfs
 endif
 
 ifeq ($(BR2_PACKAGE_MPD_LIBSMBCLIENT),y)
-MPD_DEPENDENCIES += samba
+MPD_DEPENDENCIES += samba4
 MPD_CONF_OPTS += --enable-smbclient
 else
 MPD_CONF_OPTS += --disable-smbclient