package/pkg-download.mk: add gitlab macro
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 28 Mar 2021 19:13:49 +0000 (21:13 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 28 Mar 2021 20:44:57 +0000 (22:44 +0200)
Just like we have a "github" macro to calculate the URL of the tarball
to download source from Github, let's introduce a similar macro for
Gitlab.

This should be used to download the auto-generated tarballs from
Gitlab. If there is a specific release tarball uploaded by the
upstream developers, the <pkg>_SITE variable should not use this new
gitlab macro.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-download.mk

index 4d97ef9a31f274c82f73e652ffdc1d08748f3573..2527ba5c60a3320919c785351644f2adc9b87b5e 100644 (file)
@@ -61,6 +61,9 @@ domainseparator = $(if $(1),$(1),/)
 # github(user,package,version): returns site of GitHub repository
 github = https://github.com/$(1)/$(2)/archive/$(3)
 
+# gitlab(user,package,version): returns site of Gitlab-generated tarball
+gitlab = https://gitlab.com/$(1)/$(2)/-/archive/$(3)
+
 # Expressly do not check hashes for those files
 # Exported variables default to immediately expanded in some versions of
 # make, but we need it to be recursively-epxanded, so explicitly assign it.