iptables: bump version
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Mar 2009 22:28:15 +0000 (22:28 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Mar 2009 22:28:15 +0000 (22:28 -0000)
- bump version to 1.4.2
- add uninstall target

Patch by Olaf Rempel <razzor@kopf-tisch.de>

package/iptables/iptables.mk

index fbb5f18ce34117f13732a57e02e4e62746b71958..93f2c32bed98ff04611204e9193bbf6b79cf2b96 100644 (file)
@@ -3,7 +3,7 @@
 # iptables
 #
 #############################################################
-IPTABLES_VERSION = 1.4.1
+IPTABLES_VERSION = 1.4.2
 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
 
@@ -16,3 +16,10 @@ IPTABLES_CONFIGURE_OPT = --with-kernel=$(LINUX_HEADERS_DIR)
 IPTABLES_MAKE_OPT = GLIB_GENMARSHAL=$(HOST_GLIB)/bin/glib-genmarshal GLIB_MKENUMS=$(HOST_GLIB)/bin/glib-mkenums
 
 $(eval $(call AUTOTARGETS,package,iptables))
+
+$(IPTABLES_TARGET_UNINSTALL):
+       $(call MESSAGE,"Uninstalling")
+       rm -f $(TARGET_DIR)/usr/bin/iptables-xml
+       rm -f $(TARGET_DIR)/usr/sbin/iptables* $(TARGET_DIR)/usr/sbin/ip6tables*
+       rm -rf $(TARGET_DIR)/usr/lib/xtables
+       rm -f $(IPTABLES_TARGET_INSTALL_TARGET)