toolchain: also setup kernel headers when ext toolchain is used
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 13 Jun 2008 14:28:57 +0000 (14:28 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 13 Jun 2008 14:28:57 +0000 (14:28 -0000)
Provide kernel headers when ext toolchain is used, so we can compile
packages which need them.

Makefile
toolchain/Config.in.2
toolchain/kernel-headers/kernel-headers.mk

index b6622b12df7f9b4faa65d84b86ebabfb749c196a..caabd690cf7bb8c73386a3a888f9a508140c1fca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -196,7 +196,7 @@ PREFERRED_LIB_FLAGS:=--enable-static --enable-shared
 ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
 BASE_TARGETS:=uclibc-configured binutils cross_compiler uclibc-target-utils kernel-headers
 else
-BASE_TARGETS:=uclibc
+BASE_TARGETS:=uclibc kernel-headers
 endif
 TARGETS:=
 
index c99e4fb82e31a1f85682db799a5b7051b94bf593..bac00e784e6c2774696e16b7a27e93e0b281ecd1 100644 (file)
@@ -1,7 +1,8 @@
 #
 
-if BR2_TOOLCHAIN_SOURCE
 source "toolchain/kernel-headers/Config.in"
+
+if BR2_TOOLCHAIN_SOURCE
 source "toolchain/uClibc/Config.in"
 source "toolchain/binutils/Config.in"
 source "toolchain/gcc/Config.in"
index 6cde8fba50427c35f75beff8b220116a7d1adcd2..fc8acda051e9188fb21a030588a95b128402312a 100644 (file)
@@ -6,13 +6,9 @@
 # by a 'make clean' so don't put anything sacred in here...
 #
 #############################################################
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
-DEFAULT_KERNEL_HEADERS:=$(strip $(subst ",, $(BR2_LINUX26_VERSION)))
-#"))
-else
+
 DEFAULT_KERNEL_HEADERS:=$(strip $(subst ",, $(BR2_DEFAULT_KERNEL_HEADERS)))
 #"))
-endif
 
 LINUX_HEADERS_SITE:=127.0.0.1
 LINUX_HEADERS_SOURCE:=unspecified-kernel-headers