ncurses: speed up host build by disabling static library building
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Dec 2014 21:41:33 +0000 (22:41 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 Dec 2014 21:52:32 +0000 (22:52 +0100)
For the host variant of packages, we normally only build the shared
libraries. However, ncurses uses non-standard options to select
between shared/static and therefore the host variant was building both
of them, even though the static libraries were unused.

By passing --without-normal, we disable the build of static
libraries. It saves a bit of disk space, and on my laptop,
host-ncurses takes 26 seconds to build instead of 40 seconds.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/ncurses/ncurses.mk

index 1ce3818337f88f3fb7dace2bb91600e430ce6813..645c25c1bc3fcbfbad030f5f79d34e2f68f1d000 100644 (file)
@@ -145,7 +145,8 @@ HOST_NCURSES_CONF_OPTS = \
        --without-manpages \
        --without-cxx \
        --without-cxx-binding \
-       --without-ada
+       --without-ada \
+       --without-normal
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))