haserl: bump 0.9.x version
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 13 Jun 2014 19:54:17 +0000 (21:54 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 13 Jun 2014 20:01:51 +0000 (22:01 +0200)
Fixes a number of security issues and adds support for PUT/DELETE. From the
release mail:

<snip>
Stephen Röttger reported a number of security bugs, the most serious of
which is a potential heap overflow in sliding_buffer.c (file uploads).
There is a potential for remote code execution.

At the same time, I've made an *experimental* change to allow RESTful
API's possible:

* PUT and DELETE methods are handled by the POST and GET handlers.
* For mostly historical reasons, data on the URI is still called
GET.<var>, and data in the body is named POST.<var>
* If the Content-Type is not "application/x-www-form-urlencoded", Haserl
won't try to urldecode the POST contents - it will just put the body in
POST.body verbatim.
</snip>

The lua handling now uses pkg-config, so adjust the code to match.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/haserl/Config.in
package/haserl/haserl.mk

index bfe1df838030644302fa4045ed5aaf9f0be509d7..680e280a1ad3a1ff81df0fd41eeb283a8ed0f1da 100644 (file)
@@ -41,4 +41,4 @@ endif
 config BR2_PACKAGE_HASERL_VERSION
        string
        default "0.8.0"         if BR2_PACKAGE_HASERL_VERSION_0_8_X
-       default "0.9.30"        if BR2_PACKAGE_HASERL_VERSION_0_9_X
+       default "0.9.33"        if BR2_PACKAGE_HASERL_VERSION_0_9_X
index 56240c7f817f29699871a6221af4db427f4cc48b..4b46f04a97ba71da4f6b4e79930c81fe756b3a78 100644 (file)
@@ -12,13 +12,21 @@ HASERL_SITE = http://downloads.sourceforge.net/project/haserl/haserl-devel
 endif
 HASERL_LICENSE = GPLv2
 HASERL_LICENSE_FILES = COPYING
+HASERL_DEPENDENCIES = host-pkgconf
 
 ifeq ($(BR2_PACKAGE_HASERL_WITH_LUA),y)
-       HASERL_CONF_OPT += --with-lua=$(STAGING_DIR) \
-               --with-lua-headers=$(STAGING_DIR)
+       HASERL_CONF_OPT += --with-lua
        HASERL_DEPENDENCIES += lua host-lua
+
+# liblua uses dlopen when dynamically linked
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+       HASERL_CONF_ENV += LIBS="-ldl"
+endif
+
        # lua2c is built for host, so needs to find host libs/headers
        HASERL_MAKE_OPT += lua2c_LDFLAGS='$(HOST_CFLAGS) $(HOST_LDFLAGS)'
+else
+       HASERL_CONF_OPT += --without-lua
 endif
 
 define HASERL_REMOVE_EXAMPLES