cmake: explicitly disable openssl support for host-cmake
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 18 Sep 2017 17:38:48 +0000 (19:38 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 19 Sep 2017 12:00:38 +0000 (14:00 +0200)
host-cmake will optionally link with openssl for the embedded copy of
libarchive if available, leaking host dependencies and possibly causing
build issues in case of compatibility issues - E.G. the host-cmake version
we have in 2017.02.x doesn't build against openssl-1.1.0+:

https://github.com/libarchive/libarchive/issues/810

The openssl support in libarchive is unlikely to be needed, so explicitly
disable it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cmake/cmake.mk

index e53b8aa36017e677ddbe28764a61b1103a71cee4..a00691a128ba8a72e25b8a655e7bf1032ed94ed1 100644 (file)
@@ -46,6 +46,7 @@ define HOST_CMAKE_CONFIGURE_CMDS
                        -DCMAKE_C_FLAGS="$(HOST_CMAKE_CFLAGS)" \
                        -DCMAKE_CXX_FLAGS="$(HOST_CMAKE_CXXFLAGS)" \
                        -DCMAKE_EXE_LINKER_FLAGS="$(HOST_LDFLAGS)" \
+                       -DCMAKE_USE_OPENSSL:BOOL=OFF \
                        -DBUILD_CursesDialog=OFF \
        )
 endef