janus-gateway: bump to v0.2.2
authorAdam Duskett <Aduskett@gmail.com>
Wed, 22 Mar 2017 14:13:03 +0000 (10:13 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Mar 2017 22:10:03 +0000 (23:10 +0100)
In addition, a new option sample-event-handler has been added. It has
been disabled by default in the .mk file, as it requires
libcurl. Support for it can be added later.

While at it, remove a trailing space.

Signed-off-by: Adam Duskett <aduskett@codeblue.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/janus-gateway/janus-gateway.hash
package/janus-gateway/janus-gateway.mk

index 68b9c3117bedc39432c033a23d722f32034999ad..546aff95d12723a087d25b08eb089f5c3dfab698 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 5d071592faca2a1574b996b4ca07b6c9e02cd42a719b0dbb4bfb5dfde8d55ff3 janus-gateway-v0.2.1.tar.gz
+sha256 f5b1909fd9b8546f8be518f7c682b80916a8204c95f23a95c720524df62cca34 janus-gateway-v0.2.2.tar.gz
index 212fa4739ee7e9bab2392c4d32b8b7f2b6a18744..f58db81ef2937c78add9f7ee1570fb0a9b3d840d 100644 (file)
@@ -4,14 +4,14 @@
 #
 ################################################################################
 
-JANUS_GATEWAY_VERSION = v0.2.1
+JANUS_GATEWAY_VERSION = v0.2.2
 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
 JANUS_GATEWAY_LICENSE = GPLv3
 JANUS_GATEWAY_LICENSE_FILES = COPYING
 
 # ding-libs provides the ini_config library
 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
-       libsrtp host-gengetopt libglib2 openssl 
+       libsrtp host-gengetopt libglib2 openssl
 
 # Straight out of the repository, no ./configure, and we also patch
 # configure.ac.
@@ -24,7 +24,8 @@ JANUS_GATEWAY_POST_PATCH_HOOKS += JANUS_GATEWAY_M4
 
 JANUS_GATEWAY_CONF_OPTS = \
        --disable-data-channels \
-       --disable-rabbitmq
+       --disable-rabbitmq \
+       --disable-sample-event-handler
 
 ifeq ($(BR2_PACKAGE_JANUS_AUDIO_BRIDGE),y)
 JANUS_GATEWAY_DEPENDENCIES += opus